Catalyst pre heat error - Have engine checked - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 05-09-11 Thread Starter
Status: -
AO Member
Join Date: Jul 2008
Location: United Kingdom
County: Staffordshire
Posts: 47
Catalyst pre heat error - Have engine checked

The "Have Engine Checked" warning on my 159 1.9jtdm was coming on at start up and the engine management warning remained on permanently. I took it to my local AR dealer this morning who said the fault showed as "Catalyst Pre Heat Error". On testing they could find nothing wrong and reset the error.

Has anyone had this before and what is the likely cause, as I'm sure this will come back?
bako is offline  
Sponsored Links
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
I think this type of fault may indeed be something daft and not recur.
cj romeo is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

catalyst , checked , engine , error , heat , pre

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome