New 159 owner with questions! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 20-08-11 Thread Starter
Status: -
AO Member
ricardo75's Avatar
Join Date: Aug 2011
Location: United Kingdom
County: Surrey
Posts: 90
New 159 owner with questions!

Hello all, picked up my first Alfa last weekend, a 57 plate 2.2 jts Ti! Overall really pleased with it, it’s such a nice place to be (spent 3 hours on the motorway with a big grin on my face yesterday, averaged over 40mpg too!) and I find myself stopping at the bedroom window to look at it every chance I get!

I am posting this message regarding a few minor niggles that I have, they might be nothing and I’m hoping your knowledge of the car will help me decide.

Firstly, when I first got it I was getting an annoying squeaking from the brakes when moving that would stop when I applied pressure to the brakes. Doing some research I understand that with the Brembo callipers on the Ti, this is usually caused when one of the brake pads is slightly stuck on. Over the last few days as I’ve been putting more miles on the car the squeak has now almost completely gone which suggests that the cars inactivity whilst on the forecourt might have been the issue but regardless, my plan is to get a free independent brake check to take back to the dealer and get them to service the brakes if necessary. Does that sound like a reasonable plan?

The next two things are not so much problems but peculiarities that I need to know whether they are normal for the car or signs that there might be an issue. Firstly, at low speed I am getting a whirring from the steering wheel and the steering is generally heavier than my previous car (not a problem as it makes the steering feel more direct). Now I’ve read that there can be problems with the steering that vary in remedy from changing the power steering fluid (cheap) to replacing the entire steering column (definitely not cheap!) but both of these list that the first sign is a whining noise which is not how I would describe it. What I’m getting is a more of an electro-mechanical sound like a servo (think Robocop moving his arms and legs!) so is that normal? Secondly, even with the climate control turned completely off I can still hear a faint noise through the vents, again I guess that could be normal if there is a condenser that is always on?

Also noticed when starting this morning that the oil level gauge has dropped a bar, does this seem right after 1week & 150 miles?

I need to go back to the dealer anyway to pick up some bits and pieces over the weekend but wanted your thoughts on the above as to whether they need mentioning or not, being dealer approved I have 12 months warranty and a 30-day return on the car.

I would also be interested in your thoughts on getting a Hunter alignment done? Opinion seems to suggest that the heavy tyre-wear on the 159 is caused by the Alfa standard alignment and that a more standard setup improves matters.

Thanks in advance for all your help!
ricardo75 is offline  
Sponsored Links
Status: Has a whippet
AO Member
Join Date: May 2010
Location: United Kingdom
County: South Yorkshire
Posts: 60

Member car:

159 2.2 JTS

>Squeaky brakes
Not an out and out known flaw of the 159. But I have found that leaving the car for two 1 month stints, the brakes squeaked, and on the second one a caliper had failed. Bear in mind, I'm no expert on these things - but plenty of people on here are. I think as it's brakes, don't risk it, get it checked.

>Whirring on steering
I too have the 2.2 JTS, and I don't have any noticable sound from the power steering at any speeds except when attempting to park on full lock.

>Oil level change
The oil level indicator is pretty good; it never changed in mine for 8 months until it dropped a bar and there was actually a room for some top up. Now, I've just had a service and whilst it was indicating full level, a couple of weeks on, it's gone down a couple of bars. I hadn't really thought much of it to be honest, more putting it down to the oil now having worked it's way through the guts of the engine. Perhaps we should both do it the old fashioned way and try the dip-stick.

I've never known my 2.2 to be an oil burner, nor have I ever seen anything like that on here. I would initially suggest it's just a post-service thing. But top her up and see what happens is probably the best diagnostic.

>Climate control noises
Yep, even with the engine switched off, the car blips and whirs at me.

Do do do - get the alignment sorted. It will come out of the Alfa dealership with settings not conduicive to decent tyre wear

NoveltyBobble is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , owner , questions

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome