Steering Lock - What's the Fix? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 18-08-11 Thread Starter
Status: Still engineering
AO Silver Member
Old Engineer's Avatar
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 1,927
Images: 12
Steering Lock - What's the Fix?

As noted by some other posters I have the warning "Vehicle Protection System Unavailable" about 5 seconds after removing the key.

It's the Steering Lock not engaging. Does anybody know what the fix is? Is it a new steering lock or an electronic failure?
Old Engineer is offline  
Sponsored Links
Status: If I agreed with you, we'd both be wrong
AO Member
Elfred's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hertfordshire
Posts: 693
Mine did not work for about 4 weeks so I threatened a trip to the dealer. On the morning of the dealer investigation it started to work again and has worked ever since (more than one year). Not much help I know but I'm thinking that the mechanism must stick somehow and once freed it seems to work OK so more of a mechanical problem.
Elfred is offline  
Status: -
AO Gold Member
Join Date: Jul 2006
Posts: 7,178
Just like you had to do withmechanical steering locks, sometimes a little bit of pressure on the wheel as you remove the key makes it engage.

The solenoid is replaceble
cj romeo is offline  
(Post Link) post #4 of 6 Old 19-08-11 Thread Starter
Status: Still engineering
AO Silver Member
Old Engineer's Avatar
Join Date: Mar 2003
Location: Esher
County: Surrey
Posts: 1,927
Images: 12
It sounds like the Dealer is ordering the Solenoid.

I have tried moving the steering wheel, a different key and heavy banging of the casing. It doesn't show up on the examiner but I did wonder if a battery disconnect was needed to unscramble the brain. I can't work out how it knows the steering lock is not firing and needs to put up the message. If it is purely mechanical you would think the system would fire the solenoid and not know that the plunger is not in the groove. But an electronic failure could be programmed to put up the message.

Old Engineer is offline  
Status: -
Join Date: Apr 2014
Location: Australia
County: Queensland
Posts: 4

Member car:

159 JTDm 2.4l

Steering Wheel lock

This happened to my 159 a year or so ago and I managed to get the lock mechanism off and took it apart, put it back together and it worked. This is not a job for the faint hearted, removing shear bolts is not easy, or the one way screws on the lock. It just happened again so this time after removing the key, I tapped the lock with a rubber hammer for several seconds, and after the second time the mechanism began working again. A much simpler fix .... if it works.
wiltonr is offline  
Status: Extra miaow
AO Member
Malheus's Avatar
Join Date: Apr 2011
Location: Sweden
County: Norrbotten
Posts: 775
Images: 5
I get this problem if I accidental push the key halfway back in when I'm about to remove it.
Malheus is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

fix , lock , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome