Steering problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Steering problem

Just set off into work. Got to the end of the road and the steering went all 'vague' and really heavy with a burning rubber smell. No warning lights. Turned it off and back on all fine.

Not driven since as dont fancy a repeat on the M1.

Waiting for the RAC to have a look at it, but would appreciate views.

Bit stressed, need to get to work
Sponsored Links
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
PS drive belt slipping. Get it checked ASAP!!
Squadrone Rosso is offline  
Status: - Update
Posts: n/a
RAC man has been.

Crank pulley on the power steering pump is hanging off because a lock tight wasn't used.

All the power steering stuff was totally replaced - by main dealers, in January 2010. Out of warranty, but i think totally reasonable to ask them to fix?

Trouble is I can't drive the thing until fixed and I don't have the time for a scrap with the main dealer - I need the car for work!

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

problem , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome