Engine Bay Rubber Seal Loose / Falling Off - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 11-08-11 Thread Starter
Status: Almost rattle and squeak free - one more to go!
AO Member
Ian_UK1's Avatar
Join Date: Apr 2011
Location: United Kingdom
County: Cheshire
Posts: 41
Engine Bay Rubber Seal Loose / Falling Off

I wonder if anyone can advise me with respect to the long rubber sealing strip that runs right across the car at the back of the engine bay?

On my car (159 SW 2.2) this strip is not only very loose - it wobbles back and forward and doesn't seem to have any grip on the metal underneath it - it also keeps partially falling-off into the engine compartment, leaving engine bay heat and fumes to be drawn into the car.

I'm guessing that either the seal is very worn or there is another part missing? So it begs two questions:

1) Is this seal just supposed to be pushed down over the metal strip/lip underneath it and grip it strongly enough to stay where it is? Or...

2) is there supposed to be another part that fits over the metal strip/lip before the rubber seal?

If it's 1, I need a new seal, if it's 2, then there's a part missing off my car.

Thanks in advance if you can tell me how to sort this.

Ian from Manchester, UK
(Certifiable Car Nut)!

Current Alfa: 159 Sportwagon 2.2 JTS
Previous Alfas: 156 2.5, 164 3.0, 75 3.0
Other Current Cars: Porsche 997S Gen-2 PDK, BMW Z4 sDrive 23i

Last edited by Ian_UK1; 11-08-11 at 16:20.
Ian_UK1 is offline  
Sponsored Links
Status: -
Club Member
Membro Premio
BigGinge's Avatar
Join Date: Sep 2006
Location: United Kingdom
County: Oxfordshire
Posts: 958
I can't help too much with this, but the one on my Brera slightly comes off at a point in the middle where there's a plastic panel rather than the metal lip. I keep clipping it back on, and it keeps slipping off.
BigGinge is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

bay , engine , falling , loose , rubber , seal

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome