Mike D - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 7 Old 08-08-11 Thread Starter
Status: -
Join Date: Aug 2011
Location: United Kingdom
County: Wiltshire
Posts: 2
Mike D

159 2.4 JTD
Total loss of power?
Had my 159 2 years, an 08 plate, been very good untill 3 months ago, been in the garage mostly since!
EGR valve replaced twice, and loads of other stuff along the way but still not right, it will just lose all power when you turn a corner and not pick up again, just die.
Nothing shows up on engine test, no faults show.
Any help & suggestions more than welcome, by me and dealer!!
DuhigM is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Derbyshire
Posts: 129
Its an Alfa.
It's what they do.
benskia is offline  
Status: - Update
Posts: n/a
Welcome to AO!

Check for loose battery and ECU connections?

Originally Posted by benskia View Post
Its an Alfa.
It's what they do.
That's not very helpful.

Have you thought about posting over in the MiTo Technical Lounge?

Last edited by Nev; 08-08-11 at 21:10.
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Originally Posted by benskia View Post
Its an Alfa.
It's what they do.
Camponology finish......
Squadrone Rosso is offline  
Status: A Vax and two 'Henry's
AO Silver Member
cas's Avatar
Join Date: Feb 2008
Location: Canterbury
County: Kent
Posts: 2,335
...ringing terminate?

cas is offline  
Status: -
AO Member
colins's Avatar
Join Date: Feb 2004
Posts: 169
Well Happy

Originally Posted by benskia View Post
its an alfa.
It's what they do.
colins is offline  
Status: BORED
David P's Avatar
Join Date: Aug 2003
Location: Ireland
County: Cork
Posts: 74,627
Images: 20
Originally Posted by colins View Post


Not all Alfas are unreliable, a bit like all other manufacturers really

OP : Hope your Alfa gets sorted
David P is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome