3.2 Excessive Oil Consumption - or not ? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 01-08-11 Thread Starter
Status: shush !! what's that rattle ?
AO Member
frozen-north's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Aberdeen
Posts: 335
Images: 1

Member car:

Brera 3.2 Q4 SV

3.2 Excessive Oil Consumption - or not ?

Ok guys, well those of you with the 3.2l. I'm used to the bella drinking a little oil, typically from max to min over the course of a year, but lately she's got a bit more thirsty. The car's got 50k on the clock with the first 5k as Western Alfa's demo.

She was in for an engine out to replace the oil level sensor about 9 months ago so I can't be exactly sure what was happening in the few months before, but since then she's gone through about a litre. Day to day it's not noticeable but after a v long run (500+ miles) or periods of spirited driving (damm those AONS runs ) it apears to hasten the issue.

In the middle of nowhere (well SE Essex) the first time it asked for a top up so it's been topped up with Millers XFS rather than Selenia.

There's no evidence of it leaking out, and the engine seems to be running tip-top without any noticeable noises or smoking. Has anyone else noticed this trait with the engine now it's properly run in, or does anyone think it's a bigger issue and requires some immediate further investigation ?

frozen-north is offline  
Sponsored Links
Status: New car itch scratched!
AO Silver Member
zeffsofresh's Avatar
Join Date: Dec 2010
Location: South Africa
County: Gauteng
Posts: 1,301
Images: 15
Mine does exactly the same! I was a little worried, but after speaking to three dealerships and one private mechanic, and having heard them all sing the same story about it being quite normal, I'm not tworried about it anymore. After a routine service at my local dealer he told me they used a 10w60 spec oil which would help a little. I can't say its made any difference, but I bought myself 5 litres of Castrol edge sport 10w60 and I top up about everymonth and a half to two months. I've used a little over a litre in the last 8 months.
zeffsofresh is offline  
Status: - Update
Posts: n/a
Mine doesn't seem to use a drop at the moment, but it only has about 14.5k on the clock.
Status: temporary ex-alfa owner
AO Member
thebassman's Avatar
Join Date: Oct 2010
Location: United Kingdom
County: Fife
Posts: 161

Member car:

MB C Class coupe

I've put 6k miles on mine since I got it with 50k on the clock. I've never had to top it up, unlike my previous A6 2.4 which needed topped up every other month.
thebassman is offline  
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Mine uses nothing. Not a drop, even after Oulton & a France run. 25k miles.

GTleigh's used nothing either during the 60k hard driven miles he had his.

Squadrone Rosso is offline  
(Post Link) post #6 of 6 Old 02-08-11 Thread Starter
Status: shush !! what's that rattle ?
AO Member
frozen-north's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Aberdeen
Posts: 335
Images: 1

Member car:

Brera 3.2 Q4 SV

Ach well, I'll stick with the top ups and keep an eye. Due an MOT next month so I'll ask if there's any evidence of it burning a little oil. At £8.60 a litre I'm sticking with the Millers as well .
frozen-north is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

consumption , excessive , oil

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome