Brera 2.4 - Engine Warning Light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 07-07-11 Thread Starter
Status: -
Join Date: Jul 2011
Location: United Kingdom
County: Norfolk
Posts: 1

Member car:

Brera 2.4

Brera 2.4 - Engine Warning Light


I have been recently experiencing an array of various problems with my brera, I shall try to list them, hopefully someone can help me shed some light on the issue.

Firstly, the engine warning light has recently started to appear quite randomly with the message 'Have Engine Checked'. The warning light only ever appears whilst driving and puts the car into 'limp' mode, it will only disappear when the car is restarted (and not always is this at the first attempt). when the car is restarted even if the light does stay on normal revs and power has returned.

I last week had it serviced with the Alfa dealership in Norwich, along with front brake discs and pads changed. It was put onto diagnostics had the error code related to a 'Flow Shutter Valve' error, as the warning light was not showing the error code was reset.

Within a day or so, I began to notice that the car seemed to struggle to 'idle' almost as if it was going to stall, I took it back to garage and again it was put onto diagnostics, this time the error was related to the 'Throttle Assembly', they cleaned and replaced a couple of parts and for the first 10 miles the car was incredible...

Then the engine warning light returned and now the car when on partial throttle seems to shudder or struggle to accelerate... I ve also noticed that the cruise control has stopped working since the 'shudder' has started...

It is again going back to Alfa who are saying the problem is related to some valve and maybe the throttle assembly needs replacing too...

Does anybody know what the issue may be here? Could all the issues be related and/or is alfa's diagnosis right... I have read a lot of forums on this which suggest there may be other issues such as sticking injectors...!?

Any advice would appreciated
GurkaFoxtrot is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , engine , light , throttle , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome