Brera Issues : Power / Noises - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 04-07-11 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 29
Brera Issues : Power / Noises

Have just completed a 2,600 mile trip to the south of France (av mpg 41.4 ave speed 41), great GT car for long trips, munches the miles like no other BM's included.

As with all my Alfas there is a but:

The DPF regen seemed to be taking place every c 340 miles , is this normal ? engine seemed to be running on three cylinders, lack of power had to drop to 4th and floor it to keep going, after a few miles all was well again.

Suspension noises, noticed when crawling in traffic and coasting either in gear or neutral there is a grinding/clicking noise from the front end, this dissappears when under power, Sounds like a wheel bearing, (car has done 21,000 miles).

Also when traking up drive from a stand still there is a clunk from the front end as though something is loose.

Any ideas?.

robbie1007 is offline  
Sponsored Links
Status: -
AO Silver Member
stevepen's Avatar
Join Date: May 2010
Location: Stockport, Cheshire
County: Cheshire
Posts: 1,759
Images: 4
The regen seems normal at that miles but mine never looses any power. Maybe your egr needs a clean out.

The suspension noise could be the front wishbones.
stevepen is offline  
(Post Link) post #3 of 4 Old 05-07-11 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 29
Got out and under last night, found the problem (I think) two of the wheel bolts were LOOSE! tightened up no more noise.... simples now for the EGR.
robbie1007 is offline  
Status: Alfaless!!
AO Silver Member
phil-gtv6's Avatar
Join Date: Aug 2006
Location: United Kingdom
County: West Sussex
Posts: 3,073

Member car:

E82 125i

I was just about to suggest wheel bolts !
phil-gtv6 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , issues , noises , power

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome