Brera 2.4 JTDM starting problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 27-05-11 Thread Starter
Status: -
Join Date: Nov 2010
Location: United Kingdom
County: Hertfordshire
Posts: 1

Member car:

Brera diesel

Help Brera 2.4 JTDM starting problems

Hi there,

I bought an 06 plate brera with 55k on the clock in November. I immediately had it serviced as there was some shaking in the steering and was completely off-balance. Spent a ridiculous 1k on the service which included an oil and filter service. This was done by Veloces in Barnet. Promised myself, never to return to them again!

Last week, i was driving the car normally, went to a movie came back and tried to start the car. It started and then immediately cut off. Each time, the same thing would happen. Had to call breakdown the next day.

Couldn't figure out was wrong and Breakdown ended up towing my car to a specialist i found on the internet - Alfaman Services in Rayners Lane.

They had the car for almost a week and finally figured out the problem - the High Pressure Fuel Pump or so i'm told. They said new, this part would cost over 600 but he had a second hand one for 200. He told me there would be a considerable labour charge as he would need to get to the pump and he may as well do the Cam belt whilst he's there.

As i couldn't take the car anywhere else, i asked him to do it. Here's a breakdown of what was done:

Replace High Pressure Fuel Pump with second hand unit, Charge battery, carry out Full Diagnostics, Replaced Water pump, Cam belt, and Tensioner, Desludge Engine oil, Replace engine oil and filter and oil and air filters, Remove the butterfly and EGR valve - cleaned and tested, remove the in-take Manifold and test. Re-do Diagnostics and re-set. Engine now runs smoothly with no smoke. Total Time 10 hours.

For all this i was charged yet another 1200!!! That's almost 2500 i've spent on Servicing and repairing the car in 7 months!!!

As you can imagune, i'm fuming!!!! So can anyone tell me if this 1200 was well spent based on the above?

I also have a very high squeeky noise when going round roundabouts and bends around 20mph or less. I've ignored it by putting the music up!

Alfaman has told me it's the Near-side Front Suspension Lower Arm Ball joint that has a lot of play. He has quoted me 1 hour of labour to replace it with a second hand unit at a cost of 200 + VAT - is this a reasonable price for this job, if it acutally that part?

Any help and feedback will be much appreciated!!!!

Breradude is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , jtdm , problems , starting

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome