159 key problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 25-05-11 Thread Starter
Status: -
Join Date: Jun 2008
Location: United Kingdom
County: Buckinghamshire
Posts: 6

Member car:

159 3.2 Q4

159 key problems

Hi all

Just returned to my car after work, onpened car with key bur when I put it in the ignition KEY NOT RECOGNIZED came up..................
Wife brought me spare key and all worked fine any ideas why the key has just stopped working
paulm is offline  
Sponsored Links
Status: -
AO Member
GroovyBoovy's Avatar
Join Date: Jan 2011
Location: United Kingdom
County: Durham
Posts: 328
Images: 2
Battery in key fob, or at least i hope so must be the cheapest fix
GroovyBoovy is online now  
Status: - Update
Posts: n/a
Battery is for the remote central locking, not the key immobilizer/ignition.
Status: - Update
Posts: n/a
I've had this with two keys now - the first was replaced under warranty, but now down to last key. Dealer quoted nearly 400 quid for a replacement so I decided to take the risk and paid for breakdown insurance instead!

I'd be interested if you find someone who can repair them...
Status: Leg fixed - back in the drivers seat!
AO Member
Maximus84's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Lincolnshire
Posts: 973

Member car:


400 for a key!?!?
Maximus84 is offline  
Status: - Update
Posts: n/a
They are expensive to replace and reprogram the car,
but 400 quid is excessive.

Sounds like a duff batch to me.
The RFID chip in the key should be pretty robust.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , key , problems

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome