159 after a week (and a bit...) !! - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: AO Member
AO Member
Join Date: Oct 2010
Location: South Africa
County: Gauteng
Posts: 31
Images: 8

Member car:

Giulietta 1750QV

Hi ,

I have noted your feedback regarding rattle issue and am wondering if my problem is the same as what you experienced .

When driving at say 100 km/h plus , the faster you go the louder it gets , so must be wind related , a creaking sound seems to eminate from top of front passenger door , but it could be resonating from another area. It is driving me mad with frustration.

Was this similar to what you experinced ?


carljohn is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jun 2011
Location: United Kingdom
County: North Lanarkshire
Posts: 314

Member car:

159 Ti

Blue & Me is indeed an irritation, I can't for the life of me work out why it doesn't have fast forward/reqind functionality. AFAIK it's a Microsoft thing co developed with Fiat, so they must have developed it round the time of Vista 'cause it sucks just about as much as Vista.

Well...maybe being harsh, it worked with my iPhone 4 from the start, and I can understand the need for an adapter...sort of....I mean my mates Peugot RCZ paired and played music straight from my iPhone no worries, not sure why the mighty MS and Fiat can't do it if Peugot can but anyway...

Try pressing the voice command button and say 'Stop' then turn the radio off, that worked for me and it didn't autoplay on startup

Rattles can be annoying I admit, to try pinpoint, I thought I had the windscreen rattle but the dealer sorted something in the wheel arches and that solved it, so it might be that?

I've got a rattle right at my right ear from the B Pillar is it? sounds like the seatbelt flapping or something so I'll maybe try look at that this weekend.

Economy? is the car new? probably just running in a bit if it is. My 1.9 Ti averages about 44 it seems, and if I drive hard (dont really drive it that fast usually) it doesnt fall much below 40 seemingly on average so maybe it'll get better? Mine has the more I get used to it
Chris0288 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , bit , week

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome