159 wind screen washer good tip . - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 23-05-11 Thread Starter
Status: -
Join Date: Sep 2009
Location: United Kingdom
County: Essex
Posts: 3

Member car:


159 wind screen washer good tip .

After spending approx two hours removing the sump gaurd then the wheel arch cover to get at the washer pump. To find nothing wrong with the pump, the problem was two stop ends on the underside of the screen jet body had poped out and disappeared, once I replace the plugs the jets worked perfect.
bob cadby is offline  
Sponsored Links
Status: -
AO Member
wonder_lander's Avatar
Join Date: Dec 2006
Location: United Kingdom
County: Staffordshire
Posts: 100
My 159 is missing the plugs too! Did you buy just the plugs or new washer jets?
wonder_lander is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , good , screen , tip , washer , wind

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome