Something happened to my 159.....heeeelp! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 30-04-11 Thread Starter
Status: -
AO Member
andrewf2@bigpon's Avatar
Join Date: May 2007
Location: Melbourne, Australia
Posts: 39
Something happened to my 159.....heeeelp!

Driving home from holiday in my beloved 2006 159 2.2L (Melbourne, Australia) when after travelling about 100km, the car all of a sudden started to hesitate and lose power as soon as I accelarated . I gradually lost power on a hill and noticed the "current fuel consumption" on the trip computer start climb up to unheard of levels (40 litres per 100km at one stage).

It rolled along as long as I kept my foot feather light on the accelerator but I was soon down to a crawl (20km/h) in 2nd gear on any hill. I was able to nurse the car home and thought it might have been dirty fuel, but once I turned the engine off and restarted it was fine....then the same thing happened again after 100km....then was fine again once I stopped and re-started the car.

There was no pinning sounds, no warning lights and gears felt fine. Anyone experienced anything like this before. I'm stumped...and worried! It's been the most reliable car I've ever owned until now and I've done 102,000km of mostly freeway driving.

Hope you can help!
andrewf2@bigpon is offline  
Sponsored Links
Status: Back in Black
AO Silver Member
Dougie166's Avatar
Join Date: Aug 2006
Location: United Kingdom
County: Clackmannanshire
Posts: 4,103
Images: 9

Member car:

Alfaless :( BMW!

Dougie166 is offline  
Status: -
Club Member
Membro Premio
159_kid's Avatar
Club Member Number: 1398
Join Date: Oct 2010
Location: United Kingdom
Posts: 1,848
best bet would be to get it connected to a diagnostic prog like fiatecuscan and see what error codes its throwing up
159_kid is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159heeeelp , happened

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome