SatNav - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 02-04-11 Thread Starter
Status: Waiting for some new coupes
AO Member
Join Date: Mar 2008
Location: United Kingdom
County: Hampshire
Posts: 72
Images: 3

Member car:

1.8 Brera I.I.


Hello (Again!!!!)

Need some help with my SatNav.

Drove up to Cheltenham a couple of weeks ago, using our SatNav to direct us to the destination, it worked as expected.

Returning home a few days later, we thought we would take the scenic route through the Cotswolds, again, using the SatNav.

Unfortunately, the SatNav got lost!! somewhere near Cirencester and then locked up.

I 'Stopped Navigation' and switched it off, I thought, when I switch off the engine, when we get home, it will sought it's self out.

The SatNav is still not working it's roaming around somewhere near Worthing, (we're in Fareham, Hants) there are no Satellites indicated on the screen!!

I've removed the SD Card, via the Menu and reinstalled it, with no success.

I thought I'd try the Forum, before I go back to the Dealership.


Hamish is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2010
Location: United Kingdom
County: Derbyshire
Posts: 129
I dont know the sat nav. But from reading other posts about Blue and Me, people might suggest disconnecting the battery for a while to reboot the system

benskia is offline  
Status: - Update
Posts: n/a
Serves you right for going to Cirencester.

Could be a loose GPS antenna connection?

Try the B&M/ICE lounge.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome