Hair raising experience on the M1 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: - Update
Posts: n/a
Hair raising experience on the M1

Driving from Nottingham to York today. Nice easy drive 70-80 mph, then just south of Sheffield the car started juddering really badly, felt like it was driving in the wrong gear ( I wasn't!) Very noticeable and very scary

RAC man came and gave it a good once over drove it to the next junction and back, said the car was fine and it must have been an 'air lock'. So, I drove it back to York (60 or so miles) and it was fine, no problems at all.

Will take it to the dealers for a once over, but would really appreciate views on what this could be?
Sponsored Links
Status: Relaxed
AO Platinum Member
GJ's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Herefordshire
Posts: 17,658
Images: 13

Member car:

Spider S4

10 mph over the national speed limit.....

It's the alien police
GJ is offline  
Status: -
Admin Team
Alfa Vincent's Avatar
Join Date: Nov 2005
Location: United Kingdom
County: Hertfordshire
Posts: 30,411
Images: 27
Are you sure it wasn't just a regen happening?
Alfa Vincent is offline  
Status: If I agreed with you, we'd both be wrong
AO Member
Elfred's Avatar
Join Date: Aug 2008
Location: United Kingdom
County: Hertfordshire
Posts: 693
Sounds like a regen to me. Drop it down a gear or two and keep the revs up. I used to get this a lot but oddly not anymore (oh no what have I said ).
Elfred is offline  
Status: Typing this post...
AO Silver Member
johns159's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Shropshire
Posts: 1,378

Member car:

GT 3.2V6

I had this a few times on the M5 at similar speeds, pulled into services and turned off and on and it was fine.... it was trying to regen but couldnt... dealer changed EGR.
johns159 is offline  
Status: - Update
Posts: n/a
Thanks to all, sounds like a regen. After enduring the usual alfa jokes, the RAC man could see nothing wrong, even said engine was in good condition - seeing as the bloody thing was stuck on the M1, suspect he may have been pulling my leg

Car has been fine since, but booked in for a once over, it was scary...
Status: Enjoying my Alfa
AO Silver Member
sargent's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: West Midlands
Posts: 1,309

Member car:

159 1.9JTDM

I had the exact same thing happen today and yesterday.

Yesterday, i was only doing about 50. But in 6th, it was juddering like anything. Only for a few revs mind, then dropped it down.

Today, was doing 70-80 like milomoon and had exact same experience. Very bad juddering.

Kept looking in mirror to see any smoke coming out, but nothing

sargent is offline  
Status: - Update
Posts: n/a
I took it to the dealers at the time. They did a forced regen and changed the MAF filter as it had packed up.

They said the DPF was on it's way out and would not last another month. This being back in march

Anyway 4 months down the line all is well and it's not happened again, so maybe look at the MAF?
Status: On cloud 159
AO Member
Scruples's Avatar
Join Date: Jun 2011
Location: United Kingdom
County: West Yorkshire
Posts: 103

Member car:

159ti - 2.4jtdm

Useful to know in case this happens in the future! I would have been fearing the worst as well.
Scruples is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

experience , hair , raising

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome