159 internal boot release switch on overhead panel - Alfa Romeo Forum
You are currently unregistered, register for more features.    
  • 1 Post By Nev
  • 1 Post By zeffsofresh
  • 1 Post By wildnfree
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 20-02-11 Thread Starter
Status: -
Join Date: Feb 2011
Location: United Kingdom
County: Kent
Posts: 2

Member car:

159 2007

159 internal boot release switch on overhead panel

Bought the 57 plate car 2nd hand, pretty good so far. However the overhead boot release button does nothing. Tock it back to dealer, worked twice and now again nothing. I have checked the fuse and it's fine. Any ideas, key fob release works ok.
jamiemac is offline  
Sponsored Links
Status: - Update
Posts: n/a
I found you need to lock/unlock once you've changed
the option in the set-up menu to get it working
once it's been changed/battery was disconnected etc.
Lord_of_beard likes this.
Status: New car itch scratched!
AO Silver Member
zeffsofresh's Avatar
Join Date: Dec 2010
Location: South Africa
County: Gauteng
Posts: 1,301
Images: 15
had similar issues, try the menu, go to the independant boot release option
my still gave some troubles after that, turned out it was the battery. fitted a new one and presto, I could get to my gym bag again (it was stuck in there for a while)
Lord_of_beard likes this.
zeffsofresh is offline  
Status: -
AO Member
Alfa-Forza's Avatar
Join Date: Feb 2005
Location: United Kingdom
County: Lancashire
Posts: 293
Images: 20
The overhead boot release on mine stopped working too, going into the dealers for that plus a few other things. Will post a fix if there is one.
Alfa-Forza is offline  
Status: -
AO Member
Join Date: Dec 2010
Location: I would rather not say
County: -
Posts: 291

Member car:


I fixed mine by changing the option in the set-up menu. It should be off, if I remember correctly.
cona is offline  
Status: S3 good 159 now around 260hp V good
AO Member
Filbyman's Avatar
Join Date: Jan 2008
Location: United Kingdom
County: Norfolk
Posts: 421
Images: 16
I thought I had the same problem till I discovered that if I press and hold for approx 3 seconds, it works every time. I wonder if its luck or does it have a delay to stop accidental press open with all the other buttons around it.

Try it and see
Filbyman is offline  
Status: -
AO Member
Ricoz's Avatar
Join Date: Dec 2010
Location: Denmark
County: Copenhagen
Posts: 110
there are two settings which can affect the button
independent boot and auto lock, if auto lock is activated and you haven't unlock the doors (a button with door and key logo near the gear), the button won't respond. took me few minutes to fig it out, when i got mine
Ricoz is offline  
Status: -
AO Member
wildnfree's Avatar
Join Date: Jul 2012
Location: United Kingdom
County: Gloucestershire
Posts: 24

Member car:

159 1.9 jtdm

thanks guys will look into this just got my 159 boot switch did work once then I remember playing with settings so will have another look cheers for the info
Lord_of_beard likes this.
wildnfree is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , boot , internal , overhead , panel , release , switch

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome