Brera V6 Q4 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 26-01-11 Thread Starter
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: Cambridgeshire
Posts: 5
Brera V6 Q4

Vehicle applies braking on it's own ! at about 25-30mph on deceleration, the brakes only come on for a split second, enough to dip the front slightly, been back to garage and it wouldn't do it then of course, they said no fault found on computer, when it happens the asl warning light comes on but no message, any ideas ?
Roofing is offline  
Sponsored Links
Status: Broken again...
Club Member
Membro Premio
GhostyDog's Avatar
Club Member Number: 17
Join Date: Sep 2005
Location: Right Side O The Pennines
County: West Yorkshire
Posts: 25,663
Images: 6
Seriously, find a better garage
GhostyDog is offline  
Status: Selespeed that's reliable
AO Gold Member
turbonutters's Avatar
Join Date: May 2009
Location: South Africa
County: Gauteng
Posts: 7,035

Member car:

GTV 2.8 Turbo

My guess will be the internal brake switch is badly adjusted.
If the switch detects movement of the pedal the brake assist might apply brakes and then realize nope no need for it.
turbonutters is offline  
Status: -
AO Member
Join Date: Aug 2008
Location: Cambridge, UK
Posts: 20

Member car:

Brera 3.2 JTS Q4

Are you sure it's the brakes coming on? When the traction control/ASR/something kicks in on my 3.2 Q4 it's just like applying the brakes, then comes off again, with the ASR flashing. I can repeat it by going over a hump back bridge at the kind of speed you mention.
Sharpey is offline  
Status: shush !! what's that rattle ?
AO Member
frozen-north's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Aberdeen
Posts: 335
Images: 1

Member car:

Brera 3.2 Q4 SV

Sharpey +1

The only time I can get it to happen is after going airborne with one of the wheels, about 1/2 sec after full contact it knocks the power off for a blip before sorting itself out again. I've not mamaged to get a knock as all four hit the suspension stops but then it does weigh close to a small tank.

It could be a speed sensor on one corner dropping out now and again so the car thinks something bad is happening. Untill it's sorted you might want to try driving it about with ASR & VDC disabled.
frozen-north is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider


Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome