2.2 JTS Mass Airflow Sensor - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 21-01-11 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: United Kingdom
County: Cheshire
Posts: 176

Member car:

159 2.2 TI

2.2 JTS Mass Airflow Sensor

Hi all - having a bit of trouble with this one and would appreciate your advice.
My 2.2 has a recurring temporary problem. Every few weeks it runs a little rough and slightly hesitant for a while until it has an 'episode'. It lurches, the engine seems to shut itself down slowly and progressively and a host of warning lights appear referring to failures of VDC, hillholder and others.
Each time it happens (bizarrely often after driving in heavy rain or going through a jetwash) the problem seems to diminish and after a few hours/days the engine warning light extinguishes.
The dealer says the system is logging an intermittant fault with the mass airflow sensor but as it is not a hard fault cannot rectify until the problem manifests itself permanently.
Could this also explain why the fuel consumption is so poor at the moment even considering winter driving (20 mpg around town on V-power)??
Anything else obvious that could be adrift??
Thanks for your thoughts.
willow is offline  
Sponsored Links
Status: - Update
Posts: n/a
Check the battery and it's connections.


Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

airflow , jts , mass , sensor

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome