Boot Question - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 18-01-11 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: -
Posts: 215
Boot Question

OK maybe a silly sounding question but I haven't compared the boot to any other Alfas so just don't know. The manual was clear as mud also and doesn't seem to relate to my car.

I have a 159 late 2007 2.4 diesel lusso.

To open the boot I use the key, it clicks open then I have to lift the boot from the bottom lip.

Somebody in another thread talked of either an electronic opener from inside (early models I presume) or pressing the badge at the back ??. Pretty sure my badge does nothing at all. Just a solid badge on back./

I presume they are gas struts inside and when you release latch via the key it just pops up ?

Can anyone confirm how it SHOULD work in new condition

MBadger is offline  
Sponsored Links
Status: Wondering why people buy so many Audis
AO Silver Member
Quadrofoglio's Avatar
Join Date: Jul 2007
Location: United Kingdom
County: West Yorkshire
Posts: 1,225
Only cars from about mid-08 onwards have the badge button. Earlier models it's either the button on the key or a button on the console next to the interior lamps.
Quadrofoglio is offline  
(Post Link) post #3 of 4 Old 18-01-11 Thread Starter
Status: -
AO Member
Join Date: Jan 2011
Location: United Kingdom
County: -
Posts: 215
ok great. So does the boot open up once released with Gas struts or do you have to get your fingers under the lip of it to open. It's reasonably stiff so I thought maybe gas struts.

Thanks for info - New to Alfas so don't yet have the model and history knowledge of the cars. That will change as we go along.
MBadger is offline  
Status: Mrs VD :)
AO Gold Member
mamalasagne's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Berkshire
Posts: 8,661
Images: 5

Member car:

Shiny red 159Ti

You have to lift it open
mamalasagne is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

boot , question

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome