Electronic key not recognised - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 5 Old 15-01-11 Thread Starter
Status: Walking
AO Member
Join Date: Oct 2007
Location: United Kingdom
County: -
Posts: 10

Member car:

Brera 2.2

Electronic key not recognised

Hi, Went out to my Brera just now and found it with both windows fully down. I have seen this before when I accidentally hit some combination on the key fob, so I tried to use the key in the ignition to allow me to put the windows back up. But it displayed message "Electronic key not recognised". I tried my spare key and that was Ok though.

Windows now back up, and the spare key works OK, but my main key is not working. I opened it up and the CR2032 battery inside was slightly damp (not sure if my son has been playing with it in water, or whether the battery was leaking).

Has anyone seen this error before and is there any hope for getting the main key working again?

jonotaylor is offline  
Sponsored Links
Status: Now just the 147..
AO Silver Member
lovelyred159's Avatar
Join Date: Sep 2004
Location: United Kingdom
County: Somerset
Posts: 1,949
Images: 11

Member car:

147 1.6 Lusso

Have you checked the battery in the fob is still OK? Maybe a gentle warm with Hair Dryer?
lovelyred159 is offline  
Status: - Update
Posts: n/a
The battery powered electronics part of the key is only for the alarm/locks.

The immobiliser/starter part is RFID based so isn't connected
to the battery.
Status: -
Join Date: Jan 2011
Location: United Kingdom
County: Dorset
Posts: 9

Member car:

147 1.6 ti

key card

hi had key not reconised the other day used spare (had to get lift home to get it)
dried it out still would not work . put in new battery and was fine
hawki is offline  
(Post Link) post #5 of 5 Old 23-01-11 Thread Starter
Status: Walking
AO Member
Join Date: Oct 2007
Location: United Kingdom
County: -
Posts: 10

Member car:

Brera 2.2

Quick update: the key dried out, replaced battery and working OK again now.
jonotaylor is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

electronic , key , recognised

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome