Pre heater Glow plugs not available? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-01-11 Thread Starter
Status: anniversary tomorrow !
AO Gold Member
alfamoment's Avatar
Join Date: Dec 2009
Location: United Kingdom
County: Neath Port Talbot
Posts: 11,159
Images: 21
Help Pre heater Glow plugs not available?

Anyone got any solutions for "pre Heater Glow Plugs not available" messsage?? not had cover off or anything like that, can camcel message and after few secs glow plug siganl light goes out all ok runs well no loss in power etc. anyone getting this or have a resolution?
alfamoment is offline  
Sponsored Links
Status: -
Join Date: Aug 2010
Location: United Kingdom
County: Monmouthshire
Posts: 1
Thumbs Up Pre heater glow plugs not available.

Alfa Brera 204Jtdm:- Been having this alarm on and off when starting the car. If one of the glow plugs is high resistance then alarm will activate.
Had a look under the plastic cover and found that one of the connectors on to the glow plug was loose. (No 3 cylinder) Have resecured and problem gone. Would suggest checking the security of the leads feeding the glow plug by gently pulling them?:
Rhiwderin Alfa is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

glow , heater , plugs , pre

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome