The whole car shakes violently - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 8 Old 27-12-10 Thread Starter
Status: -
robfloyd35's Avatar
Join Date: Nov 2010
Location: United Kingdom
County: Hampshire
Posts: 3

Member car:

Alfa 159

Help The whole car shakes violently

My 159 has started shaking a massive amount as I accelerate from 35mph to 80mph, but stops as soon as I take my foot of the accelerator pedal. I have had the car jacked up and had 3 mechanics look at it and don't know what it is. They all said that the car was solid underneath. I took it to a tyre place to check the balancing, I got told that one of the wheels were buckled, I had it replaced but it is still shaking and its getting worse.

Has anyone had a problem like this or have any ideas how to solve it.

robfloyd35 is offline  
Sponsored Links
Status: -
AO Member
Join Date: May 2007
Location: United Kingdom
County: -
Posts: 378
A worn drive shaft maybe ?

ptcoll is offline  
Status: 2016 . . . .Year ofthe Sprint??
AO Silver Member
StescoG66's Avatar
Join Date: May 2007
Location: United Kingdom
County: East Dunbartonshire
Posts: 3,196
Images: 17
Dual Mass Flywheel?? Just an outside guess, or a knackered engine mount?
StescoG66 is offline  
Status: Leg fixed - back in the drivers seat!
AO Member
Maximus84's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: Lincolnshire
Posts: 973

Member car:


I had a flywheel problem with my Audi A4, however the car shook most notably while stationary at idle, and wasn't as noticeable at speed.

A different engine, however (1.9TDi) and the harmonics of the car may mean the vibration occurs at different speeds.

I'm mechanic, just trying to apply some sort of logic based on my experience.

I sincerely hope it isn't the flywheel - they ain't cheap!
Maximus84 is offline  
Status: Saving for engine.
AO Silver Member
tomfromtelford's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Shropshire
Posts: 4,244
Images: 54
I'd say wheel bearing
tomfromtelford is offline  
Status: - Update
Posts: n/a
My money would be on an engine mount or suspension mount if you've already checked the wheel balance and tracking.
Status: -
AO Member
Join Date: Jan 2002
Posts: 224

my gtv had this problem and it turned out to be a worn inner cv joint. It would vibrate very badly under acceleration but would stop vibrating as soon as you lift off. Put car up on lift and with car running and going thru the gears we could see the joint moving. Replaced the inner cv joint and vibration gone. The cv joint looked ok with the rubber boot intact. Hope this helps.
chimo is offline  
Status: -
AO Member
Join Date: Oct 2010
Location: United Kingdom
County: Suffolk
Posts: 14

Member car:

brera 2.4jtdm

Could be something as simple as a misfire? my 2.4 brera did but only between 2.5 and 3000 rpm in all gears, vibrations were really bad, and a couple of my mates with 159's have had the same.
mumbles260486 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

car , shakes , violently

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome