Bonnet release fault...Help ! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 26-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Denbighshire
Posts: 3

Member car:

159 SW 1.9jtdm

Bonnet release fault...Help !

Hi guys,

just purchased a rather nice 159 SW Jtdm, great car however I do have a problem with the bonnet release.

I've tried to lube the catch and this seems ok, what seems to be the problem is that the cable is sticking in its sheath and not allowing the latch to return once pulled, therefore bonnet wont shut unless I prise catch to correct position then close it.

I've removed the cable from the mech (bonnet end) and attempted to clean and lube it to no avail. It's really not free at all.

I'm pretty sure it's going to need a replacement cable, any one undertaken this job ?

Can anyone shed any light on how the cable is changed as It's pretty awkward to trace its path

Many thanks in advance
Justin159 is offline  
Sponsored Links
Status: Enjoying my Alfa
AO Silver Member
sargent's Avatar
Join Date: Sep 2010
Location: United Kingdom
County: West Midlands
Posts: 1,309

Member car:

159 1.9JTDM


I have the very same problem. I bought my 159 the other day - and looked under the hood - and it wouldn't shut properly.

Sounds like we have the same problem. I took her to the alfa dealer locally, and he fiddled with the lever, then it shut perfectly!

I don't plan to open the bonnet unless I need to. He said everything ok, just a bit sticky.

The guy told me that i'd be looking at around 150 for a bonnet latch repair - Great!
sargent is offline  
Peter K
Status: - Update
Posts: n/a
The lever is not supposed to "Return" Once pulled open and while the bonnet is up it sticks out a fair but.

When you shut the bonnet it retracts. (if functional)

The locking mechanism is prone to collect grit and muck, so try cleaning it out once in a while and spraying WD-40 afterwards. This should keep it fully functional.

Replacing the locking mechanism is simply DIY job. We sell the units, I think it's around the equivalent of 60 , so €150 sounds a bit OTT
(Post Link) post #4 of 4 Old 27-09-10 Thread Starter
Status: -
Join Date: Sep 2010
Location: United Kingdom
County: Denbighshire
Posts: 3

Member car:

159 SW 1.9jtdm

Hi Sargent, it does indeed sound like we have the same fault....looking at the triple light cluster you need the bonnet up to clean them properly. In a funny way though it's testament to the 159's reliability that the bonnet sticks closed

Pete K: The pull lever itself doesnt return but part of the mechanism (latch end) does. If it doesn't you get the fault described by Sargent where if attempting to close the bonnet it will not shut at all until the part of the latch which is spring loaded retuns 5mm or so (I do this with a flat bladed driver), this then allows the latch to correctly receive the bonnet and then shuts.

The reason it doesnt return to the correct place is the excessive resistance caused in my opinion by the faulty cable which stops the part of the mechanism moving back as described above.

Basically I'm still in need of any advice on replacing the cable itself !! Help please !!
Justin159 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

bonnet , faulthelp , release

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome