159 engine light mystery - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 29-08-10 Thread Starter
Status: -
AO Member
lorenzo 147's Avatar
Join Date: May 2008
Location: preston
Posts: 10

Member car:

147 1.6 ts lusso

159 engine light mystery

hi all,

ive got a 159 56 reg 1.9 jtdm and ive got the engine light on. ive taken it to ferdi's in lytham to connect it up to his computer and it comes up with 'pre cat temperature, signal not plausible and the code 2080'

anyone any ideas on what this could mean? and whether its anything serious?

also another question. i have a problem with the swirl valve and the rod that connects them, it keeps coming off and the 4 holes that connect it to the valves are worn. is it worth replacing the whole manifold to fix the problem? as i cannot seem to get a replacement rod anywhere.

any help is much appreciated!

lorenzo 147 is offline  
Sponsored Links
Status: ...
AO Member
Join Date: May 2010
Location: United Kingdom
County: -
Posts: 387
The rod's probably come off because the manifolds blocked, so a new manifold is a good idea, and also cleaning the egr valve while you're at it wouldn't hurt. As for the code, i'm not really sure, possibly the exhaust temp sensor itself is faulty, but theres probably tests you can do on the sensor/wiring first.
Stibbs is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , engine , light , mystery

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome