159 on / off vibration - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 31-07-10 Thread Starter
Status: 00 V 00
AO Silver Member
alfamj's Avatar
Join Date: Jul 2010
Location: Ireland
County: Dublin
Posts: 1,313
Images: 16

Member car:

'05 350z

159 on / off vibration

Hi Folks,

My dad owns a 2006 159 1.9 jtd 8v. Fortunately i get to drive it too and what a magnificent car Theres just over 70k miles done on the car.

My father and I have noticed that when driving around town, in 4th of 5th gear at approximately 1,500rpm, there is this on / off shuddering feeling- like a slight speeding up and slowing down sensation. I'm not exactly sure what is happening- I thought a) initially it might be something to do with turbo engaging and disengaging, b) I have noticed the clutch pedal is a bit slow to disengage- as in it feels a bit heavy / sticky or c) something up with the fuel injectors?

Have any of you guys have had any issues with this? Any feedback would be much appreciated.

Many thanks,
alfamj is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , vibration

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome