Engine Management Light - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 29-07-10 Thread Starter
Status: ready to race
AO Silver Member
rafe005's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Devon
Posts: 5,244

Member car:

159 1.9jtdm

Engine Management Light

It just had to happen didnt it, less than a week into owning a 159 1.9jtdm and the engine management light comes on. No loss of power (it does seem to sound a tiny bit more dieselish) or any other obvious running faults.

Anyone else had this or is there a common prognosis for the light coming on? Its at 68k miles with full service history and I do have it booked on a diag machine on sat morning but any thoughts would be kindly appreciated.

I am however wondering if its throwing a strop because I have been talking about fitting it with a towbar

Website www.mansellracing.co.uk

No.3 of the NORM collective

UNDERSTEER is when you hit the wall with the front of the kart
OVERSTEER is when you hit the wall with the rear of the kart
HORSEPOWER is how fast you hit the wall
TORQUE is how far you take the wall with you
rafe005 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

engine , light , management

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome