Juddering during regen - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: I'll be back in an Alfa 1 day
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 261
Think yourself lucky. I tow a caravan and went away at the start of the week. Followed a Sunday driver on some country lanes so was only doing 40-50 in fourth. Got to about 2 miles from camp site and the engine light came on - failed regen again. Managed to get to site with the caravan but had been trying all week to clear it - no power and only managed 50mph. Came home today towing the caravan (which is quite heavy) and only managed 55mph on a straight - up hill was down to 2nd gear up to a max of 3k revs. Managed to get home (all 70 miles of it) and took car for a blast on the A1 - 20 miles round trip in 4th at 70mph done the job. All clear again until the next time....
lanceshaw is offline  
Sponsored Links

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

juddering , regen

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome