159 Rear Window Regulator - Issues - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 14-07-10 Thread Starter
Status: -
Join Date: Jul 2009
Location: Australia
County: New South Wales
Posts: 6

Member car:

159 JTD

159 Rear Window Regulator - Issues

Anyone else had issues with the rear window regulators?

About 6 monhts ago my RHR window just dropped and whilst the motor seemed to be turning the window would not wind up. Dealer installed a new regulator and having a look at the old one they took out it seemed that a small plastic part was broken. Alfa offered to pay half the cost of the spares (and probably still made money on it) and thinking that it was a one off and bad luck I agreed to get it fixed.

Now I find that the same thing has happened to the LHR window.

Now the rear windows really don't get used much. 99% of my driving is done on my own and I can count the number of times I have had rear seat passengers on both hands.

To have both fail with little use tells me that there is a design or manufacture problem and if so someone else must have experienced it as well.

The car is a 2006 2.4 JTD

Overall I am happy with the car but I will be unhappy to pay AUD700+ for a new reg especially when I am not sure that the issue won't reoccur.
Chrisblue is offline  
Sponsored Links
Status: -
AO Member
Kras's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Surrey
Posts: 167
ive had all 4 regulators changed.
No randon window dropping, it was just when closing the doors with the windows down the glass had no firm contact with anything and rattled to the point of it could have shattered if the door was slammed.
Kras is offline  
Status: No more warranty!
AO Silver Member
twissler's Avatar
Join Date: Jan 2009
Location: United Kingdom
County: Cheshire
Posts: 1,051
I had a similar experience with my old 156. I just took the regulators out and gave them a good spray with electro lube. All that had happened was that the regulators had seized due to lack of use. They worked fine after this and even now on my 159 I always operate the rear windows every couple of weeks to prevent this happening.

It is probrably a case of Alfa using crap regulators. Just operate the rear windows now and then and hopefully this won't happen again.
twissler is offline  
(Post Link) post #4 of 4 Old 15-07-10 Thread Starter
Status: -
Join Date: Jul 2009
Location: Australia
County: New South Wales
Posts: 6

Member car:

159 JTD

Thanks for the replies guys.

Possibly it is from under use but the internals of the last one that was replaced had the wire all mangled, whether that was a cause or result it is difficult to tell.

I will report back on how I go with Alfa Australia. Have to tell you though that I won't let my next Alfa (if I do buy another) go past the 3y warranty period.
Chrisblue is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , issues , rear , regulator , window

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome