159 2.4 Two Years of Ownership - Report - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 4 Old 02-07-10 Thread Starter
Status: quo ante bellum
Club Member
Membro Medio
Stewart1's Avatar
Club Member Number: 505
Join Date: Aug 2007
Location: Australia
County: New South Wales
Posts: 1,230
Images: 11
159 2.4 Two Years of Ownership - Report

My 159 2.4 JTD was delivered at the end of June 2008 (it is a December 2007 build according to the sticker in the boot, so pre-dates the factory shut-down in early 2008 and the small design changes that were made at that time). It is now two years into a three year lease. I posted an update after the first year, so here is another one.

The car has done a bit over 57000 km, with a significant amount of that being long-distance driving, some in Australian summer temperatures.

Reliability (engine, transmission, electrics and brakes) - 100%

Issues requiring service: only one. After 18 months I lost all the gas in the aircon. Turned out to be a crack in a pipe which was being fouled by the windscreen wiper mechanism. Repaired under warranty. When a new part arrived (from Italy!) it had been completely redesigned to avoid contact with the wiper gear.

Other minor issues: 1. after a few weeks the gear knob came loose. Tightened it. After a few more weeks it came loose again. Applied Loctite and tightened it. Has not come loose again. 2. After six months the windscreen was cracked by a stone. When replaced, the new one suffered from the dreaded windscreen creak. Application of silicone spray roughly every six months keeps it away. 3. Tyre wear: not too bad compared with the experiences of others on here. Have just had the third set of Pzero Neros fitted.

Still very happy.

Alfa Romeo 159 2.4 JTD in Pinot Grigio
Stewart1 is offline  
Sponsored Links
Status: 6 cylinders. Big smile.
AO Silver Member
wynne71's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: West Midlands
Posts: 5,064
Excellent news!

My air-con lost its gas as well, found another pin ***** hole near the compressor, a right pain to fix.

Glad yours is running well. The faults that you have had are minor, if a little annoying at the time.
Hope it continues to treat you well!
wynne71 is offline  
Status: Love driving the 159
AO Member
BiggaJ's Avatar
Join Date: Jun 2010
Location: United Kingdom
County: Cheshire
Posts: 43
Glad to hear you are have a reliable Alfa, so many still seem to get problems. Yours seem the sort of problems many manufacturers would get. Mine has been totally reliable through out also.
BiggaJ is offline  
Status: New old Spider owner
AO Silver Member
chuckyb's Avatar
Join Date: Aug 2009
Location: Australia
County: New South Wales
Posts: 2,061
Images: 10
Nice to hear a positive report. Hope it stays that way. Look forward to reading the three year report.
chuckyb is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , ownership , report , years

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome