Spider: pulling to left and steering wheel off centre - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 09-06-10 Thread Starter
Status: -
AO Member
Join Date: May 2010
Location: I would rather not say
County: -
Posts: 20

Member car:

Spider 2.2JTS

Spider: pulling to left and steering wheel off centre

Long time lurker, first time poster, etc. Hopefully you can help with an annoying issue.

I've a 2007 2.2jts Spider - right hand drive. After putting on new tires recently I noticed the steering wheel was off centre about 5/10 degrees anti-clockwise, and the car was pulling gently to the left. (Tyre pressures were checked and I tried it on several different roads - it wasn't just the road camber.)

I had it back to the tyre fitters today for a full four wheel tracking / alignment - but the steering wheel is still off centre and it's still pulling to the left. Any thoughts?
windandwave is offline  
Sponsored Links
Status: - Update
Posts: n/a
Did they centre the wheel before doing the alignment?

Sounds like they did a bit of a monkey job.
Status: -
AO Member
Join Date: May 2008
Location: South Wales
Posts: 52

Member car:

Not an Alfa

I have exactly this on mine. Like you, it's pulling slightly to the left and the wheel alignment place said it was fine. Will be taking mine in for it's service in the next month so I'll mention it then.

Sure I've heard others mention similar - maybe it's a common issue?
reginaldo is offline  
Status: waiting to buy a weekend car
AO Silver Member
Seasider's Avatar
Join Date: Apr 2008
Location: United Kingdom
County: Cheshire
Posts: 3,130
Images: 3

Member car:

Various VAG

my steering wheel is a couple of degrees (most probably 1 notch) out from being perfectly straight ... couldnt be bothered to ever get it looked at

as to it pulling to one side ... on a flat level road mine is fine ... but as soon as there's truck/lorry 'tracks' on the road the car will follow them ... problem with big wide tyres !
Seasider is offline  
Status: quo ante bellum
Club Member
Membro Medio
Stewart1's Avatar
Club Member Number: 505
Join Date: Aug 2007
Location: Australia
County: New South Wales
Posts: 1,230
Images: 11
When my 159 was new it had a strong pull to the left. Got it aligned at the first service, without any noticeable improvement. Then after a few months I got the tyres changed front to back to even out the wear. Bingo - no more problem with the tracking.

Apparently it only takes one front tyre to be a little bit larger than the other to cause tracking problems.
Stewart1 is offline  
Status: -
AO Member
amiger's Avatar
Join Date: Dec 2008
Location: Israel
County: Tel Aviv (Gosh Dan)
Posts: 183
Images: 23

Member car:

159 Tbi SW

You mentioned it started after a tire change.
This might be a problem in the tire itself.
To check this try swapping rear to front if your tires have a rotation direction or left to right if they don't.
amiger is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

centre , left , pulling , spider , steering , wheel

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome