Limp Mode: 07 Brera 2.4 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 31-05-10 Thread Starter
Status: -
Join Date: Feb 2005
Location: watford
Posts: 6

Member car:

2.4 Alfa Brera

Limp Mode: 07 Brera 2.4

I appear to be suffering form the dreaded limp mode again

This first happened last August at the start of 9 hour drive back from Bordeaux, I managed to get home by a retstart every time the power dropped off, this was in the first month of ownership! The dealer reloaded the map, which I was sceptical of but it has worked until now.

For the last month I have suffered from intermittent engine warnings and limp mode, all cured by restarts and the fault light clearing fairly quickly. One think I have noticed is that the car is fine on A roads, around town but shortly after I achieved 80mph/2000rpm ish after a short period of time the engine warning light appears and I am in Limp mode.
I dont do a lot of miles and vary between town/motorway driving.
The car is due back to the dealers tomorrow and before I get another map reload as the solution I wondered if anybody have some more specific info that may be useful.
Many Thanks.
oakerz is offline  
Sponsored Links
Status: -
Join Date: Oct 2011
Location: United Kingdom
County: Essex
Posts: 2

Member car:

alfa brera 210hp

Cry Like A Baby limp mode

Have same problem on 210 hp brera 2007. Had reset twice. Now being quoted 1,801.30
to have flow shutter valve changed.
finalwhistle is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,618
Originally Posted by finalwhistle View Post
Have same problem on 210 hp brera 2007. Had reset twice. Now being quoted 1,801.30
to have flow shutter valve changed.
We can do it a good bit cheaper than that - give us a call tomorrow if you're interested 01582 869 560

Autolusso - Alfa Romeo Specialist | Alfa Romeo Servicing, Repairs and Modifications
Pud237 is online now  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

brera , limp , mode

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome