Accelera PHI Reviews - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 19-05-10 Thread Starter
Status: -
AO Member
pipadip's Avatar
Join Date: May 2004
Location: United Kingdom
County: Derbyshire
Posts: 291
Images: 1
Accelera PHI Reviews

I know i'm not alone in having uneven tyre wear issues on my 159 TI....
Having seen that a number of people have tried the Accelera's I am interested to get some good honest feedback on their performance to date.
I know there are a few comments scattered around in various posts but i thought it would be useful to put all comments together in one place.

The most 'financially sensible' alternative seems to be 245/40/19 Falken/Kumho etc.

If you are running with these tyres, what is your honest appraisal?
pipadip is offline  
Sponsored Links
Status: 6 cylinders. Big smile.
AO Silver Member
wynne71's Avatar
Join Date: Jun 2009
Location: United Kingdom
County: West Midlands
Posts: 5,064
Have run a set of Accelera 235/45/18s on the front of my 159 for a while now. I think I am upto 7K on this set.

Since then I have had a remap, so the tyres have been tried and tested for sure.

Quiet at motorway speeds. Wear seems perfectly acceptable, I had the 4 wheels aligned and the toe-in set to zero as soon as they went on.
Grip is great, wet or dry. When really pushed the side walls do show a bit of flex, but certainly nothing to alarm me.
They were even half decent in the snow this year.

Considering the cost options of the other makes, I am very happy with these tyres. If I bother to keep the car past this month I will be having another set for the rears without question.

Hope this helps.

Moved over to the dark side

And loving it
wynne71 is offline  
Status: -
AO Member
Join Date: Mar 2010
Location: United Kingdom
County: Leicestershire
Posts: 86

Member car:

159 2.4 JTDM Ti

I have always bought Michelins on my previous cars but decided to give some cheaper tyres a go - I have had Acceleras on for about 4 weeks now and am pleased with them - I personally think they lose grip under heavy acceleration a little sooner than the Pirellis they replaced but this is marginal and I am not worried about it.

Handling wise they seem fine and they are not noisy at all.

Considering the price I think they are great and would definitely buy them again.
Sports Tractor is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

accelera , phi , reviews

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome