HELP Please -- 159 No Five Live or LW - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 14-04-10 Thread Starter
Status: -
AO Member
Join Date: Mar 2010
Location: Ireland
County: -
Posts: 10

Member car:


HELP Please -- 159 No Five Live or LW

My 159 is six weeks old - love it. But I can't get Five Live (MW) or LW on the radio.
FM works but not as good as it should. The problem is the aerial.
From reading posts here I decided to get a cheap aerial in Halfords and once I plug this into the back of the radio everything is fine - normal five live.
Has anybody had problems with 159 aerials - I read some stuff about ampliiers.
Marodon is offline  
Sponsored Links
Status: Getting settled...
AO Member
Senocular's Avatar
Join Date: Mar 2010
Location: United Kingdom
County: Greater Manchester
Posts: 110

You may get some more input from the Blue&Me/ICE lounge.
Senocular is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , live

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome