Poor FM radio reception - 10 plate 159 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 07-04-10 Thread Starter
Status: -
AO Member
Join Date: Apr 2009
Location: United Kingdom
County: Greater London
Posts: 28

Member car:

159 ti TBI

Cry Like A Baby Poor FM radio reception - 10 plate 159

Along with my auxilary belt, another problem I have with my brand new 159 is that the FM reception seems fairly poor. If I have AF mode on the radio is constantly cutting out as it attempts to find a better signal. I've tried removing and reattaching the arial but when as tightly fitted as possible I can still hear faint interference with the signal.

I'm having the auxilary belt fixed next Monday so I may have this looked at on the same day. Is this anything that anyone else has had suffered or had resolved in service?
thrillhouse is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jul 2009
Location: Ireland
County: Dublin
Posts: 264

Member car:

159 JTDm

As far as I know one of the connections on back of radio is the aerial connection ...might be loose at that end. Easy to remove radio and fix ...get the dealer to fix in case its something else ...
Vromm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , plate , poor , radio , reception

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome