1.9 JTDM timing belt change frequency - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: I'll be back in an Alfa 1 day
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 261
Originally Posted by jocky68 View Post
My 06 plate is on 85k and i have not changed the belt yet. Will be doing very soon though.
Mine is also an 06 plate and had 86k on the clock. Couldn't risk it anymore so went to Autolusso yesteday and had a belt change with pump and tensioners - Aircon also done too. Great service from Ned and the guys at a great price too.

Get it done as soon as possible - it can go at any time with no warnings and like mine, it is long over due.
lanceshaw is offline  
Sponsored Links
Status: Alfabook 4400+
Club Member
Membro Premio
SCGT's Avatar
Join Date: May 2012
Location: United Kingdom
County: West Dunbartonshire
Posts: 7,266
Images: 44
Stumbled across this old thread .....intervals seem to have changed somewhat ...??? Is this recession ? ......latest figure I have from a specialist independent is 35K ......confused as ever
SCGT is offline  
Status: -
AO Member
Bruce100's Avatar
Join Date: Sep 2014
Location: United Kingdom
County: hampshire
Posts: 263
Originally Posted by wynne71 View Post
Earlier 159s had the plastic type of impellers, well the 1.9s for sure.
Mine is a March 2007 build and it had the plastic ones. The people that did the job showed me, they replaced it with the metal version as a precautionary measure when doing the cam belt.
Apologies, old thread.
from what ive read the water pump fails on this engine more than others mainly due to over tensioning of the belt.
On the 1.9 Jtdm it almost wraps around it at 90 degrees which when over tensioned maybe causes stress extra pressure on the bearing.
Well that's what I read, ill make sure I check water pump for metal impellor when I change the belts this year.
Edit: Belts and pump done, last change approx. 60k ago and pump was in good condition as was belt and tensioner.
I didn't check new impellor if metal or plastic as I don't think that is the issue.

Last edited by Bruce100; 05-03-15 at 20:56.
Bruce100 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

belt , change , frequency , jtdm , timing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome