159 battery moaners - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 10 Old 09-03-10 Thread Starter
Status: -
AO Member
Nefe 159's Avatar
Join Date: Sep 2009
Location: United Kingdom
County: Greater London
Posts: 206
Images: 28

Member car:

alfa romeo 159

159 battery moaners

Since you bought your beloved 159 how long did your battery last?
Nefe 159 is offline  
Sponsored Links
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Less than a year now almost 2.
Squadrone Rosso is offline  
Status: -
AO Member
Join Date: May 2007
Location: United Kingdom
County: -
Posts: 378
Been going for 3 years now, from new.

ptcoll is offline  
Status: -
AO Member
Join Date: Feb 2008
Location: Scotland
Posts: 133

Member car:

159 1.9JTD Lusso

Same here - 3 years and original battery still going strong. Car has been great all-round - no real problems at all with reliability or performance
BirdieKing is offline  
Status: -
AO Member
Simon156's Avatar
Join Date: Jan 2004
Location: West Sussex
Posts: 159
30 months, dead as a dodo after 10 days unused.
Simon156 is offline  
Status: -
AO Member
RochesterAlfa's Avatar
Join Date: Mar 2009
Location: United Kingdom
County: Kent
Posts: 82
I keep reading about the battery going on 159's... Are there any tell tale signs when it's about to go?

My 159 is 2.5 years old now and no sign of battery problems...

(I take it this covered under warranty?)
RochesterAlfa is offline  
Status: -
AO Member
Join Date: Mar 2004
County: -
Posts: 46

Member car:

Giulietta Multi

4 years although I thought it was dead recently as it tryed to turn over then nothing.
I had a look myself and it turned out that the clamp on the positive although it couldnt be tightened any further was not making good contact on a clean terminal.
If whoever checks a battery does it between the negative and the positive clamp/fuse arrangement rather than terminal directly which is harder to get to there is a chance a good battery could be deemed dead. It seems that clamp is a bit bigger than it could be and runs out of adjustment when it needs more for a really solid contact.

This is well worth checking before spending cash on a new battery.

Last edited by mrspanner; 10-03-10 at 10:14.
mrspanner is offline  
Status: V8, baby. V8
AO Silver Member
Commanderfish's Avatar
Join Date: Apr 2007
Location: SW London
Posts: 5,559
Images: 84
Good advice!
Commanderfish is offline  
Status: Rainy day, dream away
AO Member
TseTse54's Avatar
Join Date: Aug 2009
Location: United Kingdom
County: Essex
Posts: 50
As reported on an earlier thread, my battery "died" within a week of buying my year old 159 from a dealer; it had been left unused for 2 days. The dealer replaced it without quibble, same day.
3 months later, again after being left for a couple of days it wouldn't start. The AA said it was a dead battery. Took it in to the dealer who tested various systems and discovered that the alternator wasn't putting out the voltage it should have. They replaced it and all has been fine since.
However........ there is a co-incidence involved. Both times it wouldn't start were after the only times I had used the CD player. I had set the tuner menu to turn off after 20 mins and presumed that the CD would do the same, so when I got home I ejected the disc, got out and locked up. Next time I used the car it was dead as a dodo.
Now I physically turn the player off when I've finished with it. I may be totally wrong - but I'm not risking it!
TseTse54 is offline  
Status: in training to be grumpy old man
AO Member
Join Date: Jun 2007
Posts: 95

Member car:

Alfa 159 1.9 Jtd

Two days!!! No joke, two days
Smee Agen is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , battery , moaners

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome