Lumbar support - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 09-02-10 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: Scotland
Posts: 456
Lumbar support

Now my lumbar support isn't working! The knob turns however nothing happens. Has anyone else had this? Would this be a warranty issue? Can i fix it myself - sick of phoning Western, I'm starting to feel like a stalker or a serial winger
bcampbell74 is offline  
Sponsored Links
Status: - Update
Posts: n/a
Covered under warranty, the bit thats attached to the knob must of gone loose
Status: -
AO Member
Join Date: Jul 2009
Location: Ireland
County: Dublin
Posts: 264

Member car:

159 JTDm

happened on my previous 156 was just the knob ...took off and clicked back into place ..was ok then
If not then yes that would be covered by warranty !
Vromm is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

lumbar , support

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome