'Have engine checked' warning - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 29-01-10 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: United Kingdom
County: Cheshire
Posts: 176

Member car:

159 2.2 TI

'Have engine checked' warning

Hi all. Looking for a little advice on the above message please which appeared today. Any thoughts on what could be an obvious problem with the 2.2 (2yrs old, 13k miles)
I have a lot of miles to cover next week, the engine feels and sounds fine - does it need to go in straight away or do I have a little leeway.
Yes to answer everyone's question it has had mod 4 !!
Cheers in advance.
willow is offline  
Sponsored Links
Status: -
AO Member
T9RBD's Avatar
Join Date: May 2007
Location: United Kingdom
County: Essex
Posts: 64
Images: 16
Do this get sorted? Mine is same spec and mileage and light just came on - everything feels fine!
T9RBD is offline  
Status: partying like it's 1999
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Glasgow
Posts: 860
Images: 12

Member car:

166 3.0 V6 Super

I've had this appear a couple of times since new (the first was intermittant) even though performance etc was fine. I had it checked at the dealer and the diagnostics showed it to be a faulty lambda sensor which they replaced under warranty.

It's certainly worth checking-in but if you've had a mod' done it's advisable to return to Mango's or whoever tinkered with your bits
ultraviola is offline  
Status: Still loving it :-)
AO Member
Spyder's Avatar
Join Date: May 2006
Location: United Kingdom
County: East Riding of Yorkshire
Posts: 578
Images: 9
I used to get this regular as clockwork on my 2.2, approx every 10,000 miles the warning light would pop on. Quick trip to dealer and sorted under warranty. They said it was the Lamda sensor, obviously they're not very good on the 2.2 I've never had this on my 3.2.

Engine always felt fine and I once had to go about 1500 miles before I could get in to get it sorted and it was fine.
Spyder is offline  
Status: - Update
Posts: n/a
Could be the chain or cam sensor/actuator.

Neither has been reported (on AO) to cause catastrophic failure but could eventually put you in limp mode.
Status: A Vax and two 'Henry's
AO Silver Member
cas's Avatar
Join Date: Feb 2008
Location: Canterbury
County: Kent
Posts: 2,335
I destroyed both lambda sensors when I ran over a badger (right outside Mangoletsi ) and got that warning.

..bloody car stank for a good few days
cas is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

checked , engine , warning

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome