What work have you had done on your 159? - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: -
AO Member
159john's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: Kent
Posts: 972
Images: 3
Originally Posted by 159james View Post
John, 1300 is main dealer servicing, however there are two brake fliud changes missing 85 each. the reason it is slightly cheaper is they price match my local specialist so not to loss my business. 505 seem a little on the dear side, I paid 349 and from memory that was the full price for the service, oil and brake fuild.
That's interesting James. 505 was the price displayed on the Menu board at my local Dealer. They phoned me to advise the Service was due and when I questioned why it was so expensive I was told it was because the oil filter gets replaced at 36k and the part alone is 60. The Indie checked with AR and was advised the filter is actually 160 and doesn't need replacing at 36k....... The Main Dealer didn't even try to negotiate a discount, so I went with the Specialist (and was very pleased with the service - 180 including oil change).
159john is offline  
Sponsored Links
Status: -
AO Member
Join Date: Feb 2008
Location: United Kingdom
County: Norfolk
Posts: 54

Member car:

Alfa 159 1.9JTDM

1.9jtdm 15mnth & 28k from new:-
Door wiring loom reconnected
Windscreen lubricated x3
Drivers wiper arm realigned & damaged paintwork rectified
Two front tyres(10k) & realignment
Front innner wheel arches secured

Stone chipping rear wheel arches
Rubbing noise in 1st gear
Engine management light reset by AA x2. Unknown reason
Gobbo is offline  
Status: -
AO Member
Join Date: Sep 2008
Location: United Kingdom
County: Devon
Posts: 724
[QUOTE=Gobbo;3214999]1.9jtdm 15mnth & 28k from new:-

Windscreen lubricated x3 ????????

I have read about squeaky screens. Can anyone explain the cause and a permenant cure?

Other than steering racks and clutches there doesn't seem to be much of a pattern. (Unlike the 156)
markp2 is offline  
Status: -
Join Date: Oct 2008
Location: Ireland
County: Donegal
Posts: 8

Member car:

159 2.4 Ti

MY09 2.4 Ti , 12k miles.
Windscreen lubrication x 3
Bonnet re-aligned
Windscreen wiper arm adjusted
Tyre Pressure sensor replaced
Suspension Damper
2 front tyres at 8k miles
EGR valve and something else to try to cure engine hesitation.
Wheel alignment / tracking
Wheel arch sheet metal re-profile
Blue and Me phone book is wired up wrong, only works when not stationary!!
Driver door adjusted to prevent B pillar contact.
Oh and my rear light clusters dont line up but I have just realised this after reading another thread!!
khanirl is offline  
Status: Trying to fix my 159
AO Member
Join Date: Feb 2010
Location: Spain
County: Valencia
Posts: 114

Member car:

Alfa 159 2.4

Hy mates. I have seen that you have a lot of problems with the windscreen, the steering rack and the clutch , and all of this with a very few miles. I dont think this is normal for such a expensive car.
Mine have now 27340 miles and a lot of problems. Til now I have chaged the injectors, the admission, EGR, reprogramacion, the steering fluid 3 times, etc... But my question is
Witch are the simptoms thar makes you change the steering rack and the clutches? Also I have seen gearbox repairings. Mine has problems into the 1-2 gear adn the R gear. Im preocupated.
adrianuxx is offline  
Status: -
AO Member
telfordsteve's Avatar
Join Date: Apr 2008
Location: Telford, Shropshire
Posts: 170

Member car:


I think my clutch has just gone, it's a '56 plate 1.9 jtdm with only 42,000 on the clock. Is this right for a clutch to go so soon, they say it might cost as much as 1000 to put right if the flywheel is ok?
telfordsteve is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , work

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome