159 1.9JTD from 156 2.4JTD - some help please! - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #26 of 29 Old 21-11-09 Thread Starter
Status: -
AO Member
Join Date: Oct 2007
Posts: 13
Originally Posted by TimboZero View Post
If your 156 is getting on a bit and the 159 is a lot newer then maybe the performance is there but because it is smoother in applying it , you just don't feel and hear it as much so think it's not there ?
Yes Timbo, I think that is part of it, plus the fact the the power delivery is a little different, as our friends above have mentioned.

It's a tricky one to get my head around. I have been offered just a thousand pounds for my 156 in part exchange. It's a lot of car for that little money.

As for the bits and pieces Pud, three corners are scuffed on the bumpers, none of my own making, ok I'll admit to one. Plus I've had my Alfa boot badge nicked

And I've a chip out of one of my skirts() though replacement of that wasn't included in the quote - thought it was better to try and source one from a breakers if I were to go ahead.

If I were to spend all the time developing my business instead of prevaricating I'd probably be able to afford a new one!

Still, a problem shared is a problem halved, so thanks again for all your inputs, and keep 'em coming...

AlfaRob 156 is offline  
Sponsored Links
Status: -
Join Date: Oct 2009
Location: United Kingdom
County: Wrexham
Posts: 4

Member car:

Alfa 159 Ti 1.9

I did a 0-60 in my 2001 156 2.4 Veloce before trading it in for my 2009 159 1.9 Qtronic, just out of curiosity. The 156 had 150k on the clock and in the later years started to squeel like a pig when revved (for some reason unknown to me), and pretty sure it was slower than when I bought it in 2006 after having a new MAF (?) and a taped up split in turbo air inlet (?). I only timed the two runs on my camera phone so not particularly accurate but both came in at around 12 seconds... slow, but the point was they seemed to take the same time. To be fair the Qtronic was massively slow getting up to 10 mph compared to a clutch launch (am I missing something or is slow the only way to launch an auto?) so I would say the 1.9 is quicker once moving than my beat up old 2.4 was, but it does make me think the 2.4 when new would have been superior all round. The 2.4 still felt like it had more maximum torque for the short operating window after 2000 revs that it still operated well in.
djbob is offline  
Status: Busy busy busy!
Club Member
Membro Premio
Pud237's Avatar
Club Member Number: 71
Join Date: Apr 2006
Location: United Kingdom
County: Cumbria
Posts: 41,613
Official figures are 9.4 seconds for a 156 2.4 JTD manual and about 9.9 seconds for a 159 1.9 Q-tronic. Your new 1.9 actually has more power than your old 156 but it has a whole lot more car to haul around and the auto doesn't help.
Pud237 is offline  
Status: -
AO Silver Member
RobMsport's Avatar
Join Date: Aug 2012
Location: United Kingdom
County: Buckinghamshire
Posts: 1,346
Images: 2
Personally , I think that what a car is '' worth '' isn't as important , as your total motoring costs per year.
ie. If your 156 is worth 2000 then new suspension package , new poly bushes and a remap at say 1500 ----- make it in A1 order and over the next 5 years is costing 700 a year plus tax.ins and mot's ---------------- and it will now go like hell , handle and be reliable. (There may be other costs I haven't mentioned , this is just an example thinking process)
OR ----- you buy your 12000 159 , are disappointed with power and over 5 years without any upgrades or repairs it costs you 2400 a year .
RobMsport is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

156 , 159 , 19jtd , 24jtd

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome