First squealing now "get engine checked" number 3! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 13-10-09 Thread Starter
Status: Typing this post...
AO Silver Member
johns159's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Shropshire
Posts: 1,378

Member car:

GT 3.2V6

First squealing now "get engine checked" number 3!

Ah well, winters here and in addition to the cold morning squealing on start up and from under dash area at idle its now gone into "get engine check...." again, for the third time, in just under 3 months.

Well its been running fine for the past 4 weeks, doing regens etc and was absolutely flying last week but felt slow on Monday morning, Monday lunchtime approx 100 yds from the usual place it goes into limp mode it did it again.......

Its had up to date software, new EGR, and various forced regens, even the independant who serviced it 10 days ago said it was the lowest dpf figure (40%) they had seen on a 159 that was running ok when they checked the system on computer.

Im really disappointed now..... rather than angry although i think that may change if it doesnt get fixed soon!
johns159 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

get engine checked , number , squealing

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome