MAJOR Problem!! - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 3 Old 10-10-09 Thread Starter
Status: -
AO Member
alfakombra's Avatar
Join Date: Sep 2007
Location: Greece
County: Central Macedonia
Posts: 66
MAJOR Problem!!

My bella is in the workshop as yesterday after starting the engine and while idling the engine didnt run smoothly as normal but it was like making slamm cuts while running. I stopped in a pertol station to buy and use, one of these octane αdd bottles since I had refuel the car and when I started the engine again I had the message on the front screen 'have engine checked' . I called the road assistance, load the car on the towing truck,took it in the shop where I was told that the computer showed no ignition in two cylinders... Has anyone ever heard of this... I am about to go crazy !!!! I just love my ALFA !!! and never expected this to happen...... If anyone have any idea ...I nedd HHEELLPP!!!
(ALFA 159 1.9 JTS)
alfakombra is offline  
Sponsored Links
Status: frenzied burrowing
AO Platinum Member
Fraser's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
Coil packs maybe? Should be easy to fix.
Fraser is offline  
Status: 660Nm of torqueystuff!
AO Platinum Member
Hunter's Avatar
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,150
Images: 37
Not enough info I'm afraid See what the garage says. The 1.9 petrol unit has been phased out now - a GM unit if I'm not mistaken...

Good luck and let us know what the problem is so it could help someone else in future.
Hunter is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

major , problem

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome