159 JTDm flat spot - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 05-10-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: United Kingdom
County: Northumberland
Posts: 34
159 JTDm flat spot


We have recently acquired a 159 JTDm just approaching 3 years old with 34k miles. Within a week of taking ownership the car was towed back to the dealer unable to start.

They diagnosed and replaced the EGR valve under warranty, seems to be a common problem.

This is our first Alfa diesel, so I don't know how the engine should perform since they've fixed it. My concern is that there is a definitely drop in power around 1900 rpm.

Accelerating 40-70 in 5th gear causes the turbo to spin to maximum pressure when the engine speed is ~1500 rpm, but as the speed picks to about 1900 the turbo pressure drops off, only then to come back in on full boost at 2000 rpm.

There is a definite 2nd power surge and it's not just the dials misbehaving.

Question is, is this normal for this engine or is there something else wrong?

montemike is offline  
Sponsored Links
Status: supporting a bank near you
AO Silver Member
Top Down's Avatar
Join Date: Apr 2009
Location: United Kingdom
County: West Sussex
Posts: 3,526
Images: 3
Something is wrong, take it back, its not right.
Top Down is offline  
Status: -
AO Member
Join Date: Jun 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 61

Member car:

159 TI 1.9JTD

I'm with Red. My turbo is pretty much inline with the amout of boot I'm giving the right pedal when accelerating and only drops when cruising or decelerating.
Fentyke is offline  
Status: -
Join Date: Jan 2010
Location: Australia
County: Western Australia
Posts: 2

Member car:

159 jtdm

flat spot 159 jtdm

The problem according to my local dealer and the australian importer is generic.
I had a flat spot and juddering from 1750rpm to just over 2200rpm. took it back and we changed injectors & flushed it, then the local dealer replaced the EGR vlave gasket with one that had tow holes in it rather than the standard one ( I am only going on hteir comments here, so maybe not technically accurate) anyway, the upshot is a slight judder there still if it is running on cheap deisel, (there is a lot of bad diesel in Australia as diesels are not as popular) but on BP high output diesel, the shudder is so minor it's almost imperceptible.
I find it hard to believe ther is any manufacturer to put out an engine with a flat spot as a known fault, but if you love Alfas as much as as I do then it's probably the price we pay for not driving bmw's!
scrag is offline  
Status: frenzied burrowing
AO Platinum Member
Fraser's Avatar
Join Date: Mar 2003
Location: United Kingdom
County: South Lanarkshire
Posts: 19,680
Images: 8
It is not generic and is not present across every engine, scrags dealer is wrong (as his is now tiring comment about Alfas and BMWs) . I suspect the new egr valve is faulty.
Fraser is offline  
Status: - Update
Posts: n/a
Originally Posted by Fraser View Post
It is not generic and is not present across every engine, scrags dealer is wrong (as his is now tiring comment about Alfas and BMWs) . I suspect the new egr valve is faulty.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , flat , jtdm , spot

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome