159 Power Steering - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 6 Old 02-10-09 Thread Starter
Status: -
Join Date: Sep 2008
Location: United Kingdom
County: Kent
Posts: 2
159 Power Steering

Just wondering if anyone has had any noise issues with their power steering?
I can hear a running liquid sound, from the hydraulics I presume, every time I full turn the steering wheel. I noticed it about 4-5 months ago. Doesn't affect the steering at all but I've still got a few months on the warranty if it needs sorting.
It has been back to the dealer a while ago (Lipscomb in Kent who have been v.good so far) but they said all ok. I'm pretty sure I couldn't hear the noise when I bought the alfa about 15 months ago.
SCB is offline  
Sponsored Links
Status: -
AO Member
Join Date: Dec 2007
Posts: 190

Member car:

N.Technology 156

Hi check your fluid level, Mike
alfaracer156 is offline  
Status: Typing this post...
AO Silver Member
johns159's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Shropshire
Posts: 1,378

Member car:

GT 3.2V6

This sounds a bit like the noise im getting at the moment..... sounds like its behind the dash and disappears when you apply throttle? I tried to hear it from under the bonnet but the engine noise is too loud to pick it up unfortunatly.
johns159 is offline  
Status: Breraless :(
AO Platinum Member
Squadrone Rosso's Avatar
Join Date: Aug 2005
Location: United Kingdom
County: Neath Port Talbot
Posts: 29,893
Images: 45
Very common. Probably needs the right fluid putting in. Warranty job.
Squadrone Rosso is offline  
Status: 660Nm of torqueystuff!
AO Platinum Member
Hunter's Avatar
Join Date: Dec 2004
Location: British Indian Ocean Terr
County: -
Posts: 15,150
Images: 37
Yep, change the fluid
Hunter is offline  
Status: -
AO Member
Timinho's Avatar
Join Date: Jun 2006
Location: Warrington, Cheshire, UK
Posts: 330

Member car:

159 2.0JTDm TI

I've had a big power steering noise problem for the last 55k miles and it took 4 times before the guys at the AR garage(s) managed to identify it as needing both the fluid and pump replacing.

Unfortunately the correct diagnosis didn't come until about 4,000mls after my warranty expired and after well over a month since raising it with AR Customer Care I still await an answer on whether AR will cover the cost - which clearly they should imo.

So I suggest follow the advice re the fluid, which hopefully will work (that alone was not enough for mine but my problem sounds more severe) and you'd be right to push it before the warranty runs out!
Timinho is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

159 , power , steering

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome