Variator Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 2 Old 27-07-09 Thread Starter
Status: No more Spider
AO Member
R50 MEO's Avatar
Join Date: Feb 2009
Location: United Kingdom
County: Derbyshire
Posts: 698
Variator Problems

Just collected my Spider 2.2jts from its 2 year, 18,000 mile service. The car is 23 months old and has done 10,500 miles.
Was told the the 'examiner' had identified problems with the variators and that these needed replacing (under warranty). Asked if I had noticed any sluggishness when first starting in mornings (assumed they meant the car).
Now my wife mainly drives this car (it is a girl's car after all) but I have never noticed any difference between it and my Brera 2.2jts.
Has anyone else been told they have variator problems of which they were completely ignorant?
R50 MEO is offline  
Sponsored Links
Status: Down in Devon!
AO Member
Join Date: May 2008
Location: United Kingdom
County: Devon
Posts: 216

Member car:

Alfa Spider 2.2

Yep - I took my Spider to the garage because it kept "missing" on cold mornings - the examiner showed variator faults and they agreed to replace them. Have to say that it was much better afterwards - but still had the roof fault (that is still ongoing)!
Spider 2.2 is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

problems , variator

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome