Oh no! Limp mode! - Page 2 - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
Status: Wihout heart we would be mere machines
AO Member
Vas's Avatar
Join Date: Jul 2007
Location: Switzerland
County: Aargau
Posts: 92
Images: 14
I get it...those damn spelling mistakes...I guess being in a hurry is not a good thing...

So what do we mean when we say "thrash it" ??
Vas is offline  
Sponsored Links
Status: working
Club Member
Membro Medio
andypj's Avatar
Club Member Number: 1019
Join Date: Oct 2007
Location: United Kingdom
County: West Midlands
Posts: 4,623
Images: 30
You need a large branch off a tree, you take one end of said branch and swing branch at bonnet of car. This was demonstrated on an Austin 1100 by a Mr J Cleese in an episode of Fawlty Towers many years ago. Surprised you've not seen it
andypj is offline  
Status: I'll be back in an Alfa 1 day
AO Member
Join Date: Jul 2009
Location: United Kingdom
County: Cambridgeshire
Posts: 261
Originally Posted by milomoon View Post
Just had limp mode come on in my 159 2.4 on the m62, just past Manchester, v scary.
Pulled over and phoned main dealer, they said to thrash it over 3000 revs for a good few miles and it would be fine. Just got back to York -50 or so miles, and indeed it does seem fine, in fact it seemed a little 'fresher' if that makes sense...

Anyeay, they just said to pop in to have the warning light turned off and all sorted.

Sound reasonable?
Mines doing this quite a bit lately - I keep an eye on the MPG and when it hits 26-30mpg I know that the DPF is doing its thing so I knock it into 4th at 70mph - this puts the revs at 3000rpm - about 30 or so miles later, the mpg rises and I carry on - I do a lot of Motorway miles so the regen happens quite frequently.

Sometimes the engine light comes on and I lose power, so I then take it up slowly to 70mph and stay there until I can floor it and it pulls away - normally about 40 miles. Engine light remains on and then suddenly after a couple of successful regens, it goes out (70 + quid to get it reset at Alfa dealers). I'm getting used to it now but are looking at AHM's DPF removal. Just gotta save.
lanceshaw is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

limp , mode

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome