Turbo / Erv - Problems - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 11-05-09 Thread Starter
Status: -
AO Member
Join Date: May 2008
Posts: 19

Member car:


Turbo / Erv - Problems

Please Help

I had my car in a few weeks ago after changing down a gear to overtake and the turbo just cut out and the engine symbol came on. i took it to my dealer and they said it needed a replacement ERV in the exhaust??!!

Since getting it back turbo is still cutting out on me and is also coming in later in the rev range (closer to 2,800 - 3,000rpm) and only part ‘boost’ about 1.0 - 1.2). Also cruising, especially in 2nd gear, at around 2,000 rpm it is jumping / kangarooing. When the turbo has no boost i simply stop the car, turn it off and back on again and it works!?!?!?

i think before the erv replacement the turbo was coming in around 2,000rpm and was at a boost of at least 1.2 - 1.4 all the time, is this correct?
has anyone else had this issue?

By the way i love my Alfa, the first one i have had and would not change it for the world.
Batmobile is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

erv , problems , turbo

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome