Mileage clock flashing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 11 Old 04-03-09 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 15
Mileage clock flashing

Hi Everyone

Noticed yesterday that my mileage clock was flashing. It was still recording mileage but flashing.

I turned the car off and on and the problem stopped.

Has anyone had a similar issue or do you know what this indicates?

159er is offline  
Sponsored Links
Status: -
AO Member
Join Date: Jan 2008
Location: Edinburgh
Posts: 42
Re: Mileage clock flashing

mine did this once, same solution, not done it again. most odd!
Nickt1976 is offline  
Status: -
AO Member
Bill_Green's Avatar
Join Date: Mar 2007
Location: Warrington
Posts: 249
Re: Mileage clock flashing

Hands up anyone who hasn't seen something odd like this being displayed at some time or another. Perhaps the firmware was written by the same bloke who did my mobile phone.
Bill_Green is offline  
Status: 1750TBIecusoftware.. done!.40+bhp
Join Date: Jan 2009
Location: United Kingdom
County: Merseyside
Posts: 3,480
Images: 10

Member car:

various Alfas

Re: Mileage clock flashing

A flashing milometer,in any of the modern Alfas is an indication of a can line disturbance due to a component failure(temporary or permanent)that is connected to the can line.
ALFA TUNER is offline  
Status: Has tha nowt moist?
Club Member
Membro Premio
dxechick's Avatar
Club Member Number: 31
Join Date: Jan 2006
Location: United Kingdom
County: North Yorkshire
Posts: 3,567
Images: 1

Member car:

Black 159

Re: Mileage clock flashing

It happens on my 147 sometimes if i start the engine before the car has had a chance to run through all its checks,make sure you wait for all the lights on the dash to stop flashing.
dxechick is offline  
Status: - Update
Posts: n/a
Re: Mileage clock flashing

CanBUS error, as Alfa Tuner said.

A gadget has failed to respond on the car's computer bus.

Many, many, many, many threads on this.

Try a search for "flashing" and "proxy alignment".

Last edited by Nev; 04-03-09 at 21:06.
Status: Contemplating other marques.......
AO Member
Diablo's Avatar
Join Date: Jun 2008
Location: United Kingdom
County: Greater London
Posts: 227
Re: Mileage clock flashing

Usually this means that 'something is wrong'.

Sorry for being vague but I've seen this on mine and it has turned out to be something really obscure (like the 'left handed inverted self-opposing dongle') on some occasions, and something a little bit more obvious on others (like, for instance the climate control being dead).

I've nearly become obsessive about it. (The flashing odometer, not the dongle)
Diablo is offline  
(Post Link) post #8 of 11 Old 06-03-09 Thread Starter
Status: -
AO Member
Join Date: Mar 2008
Posts: 15
Re: Mileage clock flashing

Thanks everyone

Given that it has now stopped and not happened again - I assume the problem is sorted.

Just wanted to take the opportunity to list my experiences since buying my first Alfa in Feb 08

1. 3 weeks intop ownership. Car wouldn't start, no power at all. Got AA out - the AA guy noticed that the battery connection had come loose

2. Squeaky clutch - returned and lubricated. Worked for about 3 weeks and then came back . Fixed it myself with WD40 !!

3. Creaky windscreen. Returned and fixed. Lasted for 6 weeks and then returned. Fixed it myself with silicone spray.

4. Lost all my oil !!Garage discovered a hose had come loose.

5. Uneven front tyre wear - inside edges. Tyres replaced ( not by garage) and alignment fixed ( by garage).

6. ABS, VSR, Hill Holder etc lights came on - ABS sensor had failed - garage fixed

7. Flashing mileometer

Don't care - still love it!!
159er is offline  
Status: -
AO Member
Join Date: Mar 2008
Location: Cambs
Posts: 157

Member car:

Focus + ZX9

Re: Mileage clock flashing

Mine did this a few weeks back too (flashing mileometer)
Also while it did this, I couldn't un fold my wing mirrors or open the boot!!

Restarting several times didn't solve it. In the end I had to disconnect the battery for a minute, that seemed to sort it...

Don't you just love italian electronics
adb is offline  
Status: Saving for engine.
AO Silver Member
tomfromtelford's Avatar
Join Date: Jun 2007
Location: United Kingdom
County: Shropshire
Posts: 4,244
Images: 54
Re: Mileage clock flashing

I got mine on very cold and wet mornings. Prob a connection somwhere.
tomfromtelford is offline  
Status: - Update
Posts: n/a
Re: Mileage clock flashing

Originally Posted by adb View Post

Don't you just love italian electronics
You mean: German Electronics.

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

clock , flashing , mileage

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome