clunk when reverse, suspension? - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Thread Tools Search this Thread
(Post Link) post #1 of 1 Old 25-02-09 Thread Starter
Status: -
AO Member
Join Date: Jun 2008
Location: Turkey
County: Istanbul
Posts: 10

Member car:

159 1.9 jtdm

clunk when reverse, suspension?

hi, i have been following the threads for about 6 months. great site by the way. being an owner of a 2008 159 1.9 jtdm i have a unique problem not mentioned on any thread i know. after i drive to work and enter the garage, i start the parking process. i stop, put in reverse (auto trans), car begins to move slowly backwards, when i touch the brakes first time, i hear a loud clunk just for once. dealer told me it was pads moving slightly in calipers. they changed the front pads, but the clunk is still there. i was convinced it was not a problem. but this morning, i heard the clunk as soon as the car started moving backwards without touching the brakes. i suspect a suspension problem. any ideas?
alfistanbul is offline  

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Alfa 159, Brera & 946 Spider

clunk , reverse , suspension

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

For the best viewing experience please update your browser to Google Chrome